[vtkusers] Shadow support on volume rendering

ianl ilindsay at insigniamedical.co.uk
Fri Oct 27 11:58:44 EDT 2017

Hi David,

I have finally got some time to have a quick revisit of this (was that
really a year ago!).

Long story short, I simply can't seem to get it to do anything. I have tried
inserting an OSPRayPass into the renderer (following the pattern in the
OSPRay tests), and I have also tried using vtkOSPRayVolumeMapper directly
instead of vtkSmartVolumeMapper. I should note that the pipeline I am
testing with works fine with the GPU based renderer.

I am using the latest OSPRay and embree builds from their respective
websites on Windows and VTK 8.0.1 built using VS 2017.

As far as I can see, I am getting a std::runtime_error exception in
vtkOSPRayRendererNode.cxx, line 432:

  OSPData lightArray = ospNewData(this->Lights.size(), OSP_OBJECT,
    (this->Lights.size()?&this->Lights[0]:NULL), 0);

The Lights array looks fine in the debugger with one entry as expected.

Are there any gotchas you know of that are likely to cause this? I am a bit
stuck presently.


Sent from: http://vtk.1045678.n5.nabble.com/VTK-Users-f1224199.html

More information about the vtkusers mailing list