[vtkusers] GPU antialising not working on OpenGL2

Patricio Palma C. patriciop at gmail.com
Wed May 3 23:41:31 EDT 2017

Thanks David and Ken for the suggestions.

Regarding the FXAA support, it worked nice, sadly is not what I need :(

I tried setting MultiSamples to 8 but AA is still not enabled. I forgot to
mention (and I think this is important) is that the application uses Qt 4.7
and the structures are displayed through QVTKWidget2. I found a similar
discussion on this forum and at that moment AA worked on Qt4:

Please let me know if you have any suggestion on this matter.

Patricio Palma Contreras

On Fri, Apr 28, 2017 at 8:51 AM, David Lonie <david.lonie at kitware.com>

> On Thu, Apr 27, 2017 at 8:07 PM, Ken Martin <ken.martin at kitware.com>
> wrote:
> > Try SetMultiSamples(8)  avoid SetAAFrames()  see if that gives you hat
> you
> > want.
> There's also new support for FXAA on OpenGL2 in vtk 7.1. It's a bit
> lower quality than the hardware based AA, but it might work for your
> usecase.
> https://blog.kitware.com/new-fxaa-anti-aliasing-option-in-paraviewvtk/
> Dave
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/vtkusers/attachments/20170503/8a26c0e7/attachment.html>

More information about the vtkusers mailing list