[vtkusers] Issue when loading stl

Andre Zimmer andre.zimmer at rwth-aachen.de
Sun Jan 8 05:52:17 EST 2017


I am currently experiencing issues with loading and displaying stl 
geometries in a software I created using VTK and Python. Searches have 
shown that sporadically other people have seen the same issue and it 
reappears again every year or so.

When loading an stl file I get this message:
ERROR: In ~/SOFTWARE/ParaView-v5.2.0/VTK/IO/Geometry/vtkSTLReader.cxx, 
line 461
vtkSTLReader (0x990c440): STLReader: error while reading file 
blablablainput_files/geometry/rotating_geometries/laufrad_mrf.stl at 
line 3: unable to read point.

So far so fine. But I wondered how it comes. My software worked well on 
Fedora using Python and VTK 6.3. Now I went back to OpenSuse Leap 42.2 
and I get the message from above. So I tried fixing it by installing VTK 
6.3 (in OS 42.2 7.0 is standard). This did not help. I manually 
downloaded VTK 6.3 and later the newest version with git and compiled 
it. Again I get the same message. So I thought Paraview 5.2 works well 
and probably contains VTK. I downloaded and complied it manually. This 
Paraview version opens the stl files without complaining. So I used that 
VTK and modified my system paths to work with that Python wrapper. I get 
the same error message and nothing gets displayed. I changed the error 
message in the source code of the vtkSTLreader in the VTK files that 
came with Paraview and recompiled everything. When now using my software 
with the Python VTK version I get my new modified error message which 
shows my that I am indeed using that vtkSTLReader. In Paraview it still 
opens the stl file without any problems.

Does anyone have an idea what I could do now?


More information about the vtkusers mailing list