[vtkusers] Error: no override found for 'vtkContextDevice2D'

Lodron, Gerald Gerald.Lodron at joanneum.at
Wed Dec 14 05:44:05 EST 2016

Solved, over
#include <vtkAutoInit.h>

And QVTKWidget instead of QVTKWidget2, I dont know why but works now...


Von: vtk-developers [mailto:vtk-developers-bounces at vtk.org] Im Auftrag von Lodron, Gerald
Gesendet: Mittwoch, 14. Dezember 2016 09:57
An: VTK Developer (vtk-developers at vtk.org)
Betreff: [vtk-developers] Error: no override found for 'vtkContextDevice2D'


I updated my vtk from Paraview's vtk of paraview 4.4 to 5.2 where now the opengl2 backend is enabled by default. I programmed an own app which uses qvtkwidget2 to visualize a histogram of an image which worked on my old paraview4.4's vtk. Now I get the error message "Error: no override found for 'vtkContextDevice2D'". I found some threads which say that you have to link vtkRenderingContextOpenGL, but on opengl this file is called vtkRenderingContextOpenGL2 and I am already linking it...

Any suggestions?

Gerald Lodron

Researcher of Machine Vision Applications Group
DIGITAL - Institute for Information and Communication Technologies

JOANNEUM RESEARCH Forschungsgesellschaft mbH
Steyrergasse 17, 8010 Graz, AUSTRIA

phone:   +43-316-876-1751
general fax: +43-316-876-1751
web: http://www.joanneum.at/digital
e-mail: gerald.lodron at joanneum.at<mailto:gerald.lodron at joanneum.at>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/vtkusers/attachments/20161214/d5e5eb44/attachment.html>

More information about the vtkusers mailing list