[vtkusers] vtkPlaybackWidget not working in Activiz.NET

Sunil Mathew sunilmathew at triassicsolutions.com
Wed Aug 31 04:12:00 EDT 2016


I'm clicking on the playback buttons but they do not trigger the overridden
method. I tried making the call explicitly and it does work. I also tried
some enable flags, but did not seem to work. Any help is appreciated. I got
here by trying out an example->

public class PlaybackRepresentation: vtkPlaybackRepresentation{
    public new static PlaybackRepresentation New()
        return new PlaybackRepresentation();

    public PlaybackRepresentation()

    public override void Play()
        Log("Play pressed.");
PlaybackRepresentation   pbRep    = PlaybackRepresentation.New();
vtkPlaybackWidget        pbWidget = vtkPlaybackWidget.New();
public void AddPlaybackWidget(){
    pbRep.SetPosition( 0.43, 0.05);
    pbRep.SetPosition2(0.14, 0.07);


    pbRep.Play(); // This does work, but clicking
                  // on the button does not trigger the method call }
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/vtkusers/attachments/20160831/c8d56c92/attachment-0001.html>

More information about the vtkusers mailing list