[vtkusers] Activiz with VTK6.3 compile error CS1577

Mark DeArman mark at cascadeacoustic.com
Mon Aug 29 12:31:04 EDT 2016

My code base is getting pretty outdated.  I know Matias worked up a new building FAQ and etc which would be better to follow.
 My plan right now is to start a new build the first part of next year.
 I'll use github this time instead of our internal VS Team Foundation.
 Also I'll get all the latest glue code to support WPF ripped out of our application.
 The last time I worked on the 6.2 code, I was struggling to get mummy to generate the enums correctly.  Has anyone else ran into this issue?  Was it fixed in 6.3?
   Mark DeArman
 Cascade Acoustic Research
 (253) 200-5353


 From: "maogui.hu" <maogui.hu at gmail.com>
Sent: Sunday, August 28, 2016 12:29 AM
To: "chenjianyyzz" <chenjianyyzz at 163.com>, "vtkusers" <vtkusers at vtk.org>
Subject: Re: [vtkusers] Activiz with VTK6.3 compile error CS1577   
 I don't know the reason of your errors since it's incomplete. 
 However, from my painful experience, a right CMake version might be one of the important thing in building ActiViz.. You must choose an older version rather than the newest!  For example, CMake 2.8.8 works well for me.
 If you compile ActiViz.Net with .NET 4.0, the patched ActiViz.net and mummy source by Mark DeArman is suggested. They can be downloaded from:

     Maogui Hu, Ph.D.
State Key Laboratory of Resources and Environmental Information System
Institute of Geographic Sciences and Natural Resources Research
Chinese Academy of Sciences
A11, Datun Road
Beijing 100101, China
Tel: +86 10-64889055
Fax: +86 10-64889630
Email: humg at Lreis.ac.cn

   ???: chenjianyyzz
 ????: 2016-08-27 23:38
 ???: vtkusers
 ??: [vtkusers] Activiz with VTK6.3 compile error CS1577


I try to compile Activiz with VTK6.3, using the activizdotnet from zamirkhan in GIt, unfortunately I meet the error of error CS1577, attached please see the screenshot, unfortunately some Chinese character insided, but from where you still can see what the error is. actually I have already generate myself snk, and I check  the "Kitware.VTK.CscArgs.txt", where I am sure the snk file path is correct.
can anyone help me to figure it out what's the problem and how to solve it?

Thanks in advance.




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/vtkusers/attachments/20160829/e44a5a09/attachment.html>

More information about the vtkusers mailing list