[vtkusers] ActiViz 5.8.0 recurring random AccessViolationException

Steve M. Robbins steve at sumost.ca
Mon Jun 1 09:39:24 EDT 2015

On June 1, 2015 05:35:01 AM Christophe DUPERTHUY wrote:

> There seemed to be a latent concern on the way objects were de-allocated in
> the C# wrapping within a multi-threaded application.

I'm having similar trouble with a C# application using mummy-wrapped VTK 5.8.  
The VTK part of the application essentially shows a robot manipulator 
(polydata surfaces) that we update with current joint positions to show the 
current configuration.  That part worked well for months.  

Recently, I modified it to dynamically change the colour of some of the 
surfaces and we now experience memory corruption on the C++ side.  It turns 
out that simply using VtkActor.GetProperty() [the actor is a vtkOpenGLActor] 
is enough to cause the crash -- even if I don't actually use the property to 
change the colour or anything else.  So the problem appears to be triggered by 
creating and destroying a large number of C# VtkProperty objects.

It's been tough to track down because the crash takes hours to days to appear.  
Surprisingly, adding the memory pressure thread from Christophe's September 
post did not make it crash more frequently.

> Such concern appears to be fixed with VTK-6.2.0 (we worked with Kitware from
> 6.1 to get some in house fixes integrated and these came out with VTK 6.2).
> As of now, the code we published in this thread was fixed with the new VTK
> version.

It would be great to upgrade to VTK 6.2!  But I thought that the mummy code 
doesn't work for anything past 5.8?  What are you using for wrapping?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 811 bytes
Desc: This is a digitally signed message part.
URL: <http://public.kitware.com/pipermail/vtkusers/attachments/20150601/aafb81f4/attachment.sig>

More information about the vtkusers mailing list