[vtkusers] GPU volume rendering failure on Intel HD XXXX/Iris, Windows and recent drivers

Simon ESNEAULT simon.esneault at gmail.com
Fri Jul 17 04:43:11 EDT 2015

Hi All,

We're experiencing GPU volume rendering failure on a lot (maybe all ?)
Intel HD windows system with up to date drivers.

This is reproducible in Paraview or with the GPURenderDemo example from
VTK, just load a volume and try to render the volume... Here is a result
image from paraview on a Dell Latitude E7450 (Intel HD 5500 inside), with
GPU rendering [1] and the same volume with CPU VR rendering [2].
Interestingly, the volume rendering used to work with drivers older or
equal to the version [3]. As a work around, we ask our
customers to downgrade their driver version to this one, and they're
enjoying smooth GPU rendering. But this driver is quite old and does not
support recent chipset...

I've built and tested the GPURenderDemo with the brand new OpenGL2 backend
on an affected machine and of course it does work out of the box
(congratulations for this amazing work !). But our application is FDA/CE
marked and we need to wait that this new backend is completely ready for
prime time. So for now, we have to stick with VTK 6.1 ...

Anyone has any clue ? They're some warning that pop up from paraview
related to the extension "gl_version_1_2" that could not be loaded, not
sure if that could be related ? Following this thread [4] and the fix
proposed, I've tried to replace
extensions->LoadExtension( "GL_ARB_texture_non_power_of_two" );
in the vtkOpenGLGPUVolumeRayCastMapper.cxx, The warning disappears but
there is still no volume rendering (tested with GPURenderDemo). Maybe it
needs some others extensions ?

Should I fill a bug in paraview, vtk ? Are there any plan to maintain and
maybe fix this for the old backend ?

Simon Esneault
Rennes, France

[1] http://picpaste.com/pics/Paraview-4-3-1-GPU-VR_fail.1437122217.PNG
[2] http://picpaste.com/pics/Paraview-4-3-1-CPU-VR_win.1437122267.PNG
[3] https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23339
[4] http://public.kitware.com/pipermail/vtkusers/2014-April/083584.html
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/vtkusers/attachments/20150717/cf95ea00/attachment.html>

More information about the vtkusers mailing list