[vtkusers] QVTKWidget2(), vtkQtPython, QVTKPython import error

Manjunath K E ke.manjunath at gmail.com
Fri Aug 21 13:09:41 EDT 2015


I am trying to install vtk, qt and python bindings for them.
I have used the following commands for the same.
sudo apt-get install libvtk5.8-qt4 libvtk5-qt4-dev libvtk5-dev
libvtk5.8 python-qt4 python-vtk qt4-designer pyqt4-dev-tools
 python-qt4-gl libqt4-opengl libqt4-assistant

But, When I run a program containing call to QVTKWidget2(),
I get an error saying "AttributeError: 'module' object has no
attribute 'QVTKWidget2'"

Also, If I run "import vtk.qvtk", I get an error saying *vtkQtPython*
and *QVTKPython* modules not found.

Could, anyone send me a example for designing a PyQt4 program using qt
designer (.ui file) and vtk embeddings into it.

 Thanks and Regards,

 Manjunath K E
 Help Ever Hurt Never
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/vtkusers/attachments/20150821/601eb11d/attachment.html>

More information about the vtkusers mailing list