[vtkusers] Errors in "vtkpython" interpretor (vtkpython 6.3.0.rc1 and pyQt5.2.1 )

Manjunath K E ke.manjunath at gmail.com
Tue Aug 11 07:40:17 EDT 2015

I have installed vtkpython 6.3.0.rc1 and pyQt5.2.1 manually.

If I run a python script then it is working well without any error.

But, if i run in "vtkpython" interpretor mode, i have following errors.

I have set the *$PYTHONHOME *to contain *PyQt5 *but still problem exists.

manju at iiitb-gvcl-Z800:~/manju/qt$vtkpython
vtk version 6.3.0

*Could not find platform independent libraries <prefix>Could not find
platform dependent libraries <exec_prefix>Consider setting $PYTHONHOME to
<prefix>[:<exec_prefix>]*Python 2.7.2 (default, Feb 12 2015, 18:30:44)
[GCC 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
*>>> from PyQt5.QtWidgets import **
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: /usr/lib/python2.7/dist-packages/sip.so: undefined symbol:
*>>> from PyQt5.QtWidgets import QApplication, QDialog*
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: cannot import name QApplication

*No error for below code*
>>> from PyQt5 import *

Please help.

 Thanks and Regards,
 Manjunath K E
 Help Ever Hurt Never
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/vtkusers/attachments/20150811/8d52f014/attachment.html>

More information about the vtkusers mailing list