[vtkusers] VTK + Qt integration

Nima Ajam Gard ajam.nima at gmail.com
Tue Nov 18 14:51:32 EST 2014


I am trying to integrate VTK and Qt but unfortunately for some reasons I cannot. Currently, I can run VTK's examples except those using Qt's user interface. For example, examples in tutorial work but examples in infovis cannot be run.

I followed the guide on http://www.vtk.org/Wiki/VTK/Configure_and_Build <http://www.vtk.org/Wiki/VTK/Configure_and_Build>. All parts were done successfully except :

cmake -DQT_QMAKE_EXECUTABLE:PATH=/path/to/qt-4.8.6-build/qt-everywhere-opensource-src-4.8.6/bin/qmake \
      -DVTK_Group_Qt:BOOL=ON \
when I was in VTK-build directory, it said that there was no path/to/VTK. So, I changed to VTK and removed /path/to/VTK and it worked.

Whenever I tried to build an aforementioned example, Qt says :

error:cannot find -lQVTK
error: cannot find -lvtkRendering ....
I really appreciate any help you can provide.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/vtkusers/attachments/20141118/73258dd7/attachment.html>

More information about the vtkusers mailing list