[vtkusers] Binding vtk library

Erick andres Perez alday erickandres.perezalday at manchester.ac.uk
Sun Dec 7 18:35:43 EST 2014

Dear All

I'm having problems binding the vtk library 5.8 (or 5.10) with a c++ code in ubuntu 12.04. I previously linked the 5.8 version manually using "-s /usr/lib/libvtkFiltering.so.5.8" when I compiled it. Unfortunatelly, I wipped out my Desktop.  And this is not working anymore. Also, when I download the 5.8 version and installed it, I got:

[  5%] Building C object Utilities/vtkhdf5/src/CMakeFiles/vtkhdf5.dir/H5F.c.o
/home/e/Downloads/VTK/Utilities/vtkhdf5/src/H5F.c: In function ‘H5F_build_actual_name’:
/home/e/Downloads/VTK/Utilities/vtkhdf5/src/H5F.c:2223:12: error: ‘S_IFLNK’ undeclared (first use in this function)
/home/e/Downloads/VTK/Utilities/vtkhdf5/src/H5F.c:2223:12: note: each undeclared identifier is reported only once for each function it appears in
/home/e/Downloads/VTK/Utilities/vtkhdf5/src/H5F.c:2223:38: error: ‘S_IFMT’ undeclared (first use in this function)
/home/e/Downloads/VTK/Utilities/vtkhdf5/src/H5F.c:2228:27: error: ‘PATH_MAX’ undeclared (first use in this function)
make[2]: *** [Utilities/vtkhdf5/src/CMakeFiles/vtkhdf5.dir/H5F.c.o] Error 1
make[1]: *** [Utilities/vtkhdf5/src/CMakeFiles/vtkhdf5.dir/all] Error 2
make: *** [all] Error 2

So, I installed the ubuntu vtk5-8 package:

libvtk-java, libvtk5-dev, libvtk5-qt4-dev, libvtk5.8, libvtk5.8-qt4, python-vtk, tcl-vtk, vtk-doc, vtk-examples.

But, still doesn't work.

Then, I installed the vtk5-10 version, and everything went well but I still have this binding error:

icc uvmap.cxx -Wno-deprecated -lvtkCommon -lvtkWidgets -lvtkIO  -o uvconvert
In file included from /usr/include/vtk-5.8/vtkVariant.h(35),
                 from /usr/include/vtk-5.8/vtkAbstractArray.h(45),
                 from /usr/include/vtk-5.8/vtkDataArray.h(37),
                 from /usr/include/vtk-5.8/vtkIdTypeArray.h(29),
                 from /usr/include/vtk-5.8/vtkCellArray.h(37),
                 from uvmap.cxx(5):
/usr/include/vtk-5.8/vtkStdString.h(25): catastrophic error: cannot open source file "vtkstd/string"
  #include <vtkstd/string>       // For the superclass.

compilation aborted for uvmap.cxx (code 4)
make: *** [uvconvert] Error 4

Same error if I linked like #include "vtk-5.8/vtkCellArray.h" or #include "vtk-5.10/vtkCellArray.h"

Any help would be really apreciated.

Best regards

Erick Andres Perez Alday
Biological Physics Group
3.17 Schuster Laboratory
University of Manchester
M13 9PL
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/vtkusers/attachments/20141207/f35f3d92/attachment.html>

More information about the vtkusers mailing list