[vtkusers] vtkImageViewer2 not rendering until I reset

Marcos fotosentido at gmail.com
Thu Aug 14 06:24:53 EDT 2014


I've showed a dicom image successfully with vtkImageviewer. Then I realized
that vtkImageviewer2 would be more suitable, as I needed interactors and
load images with slices, maybe 3d, etc

So I changed to vtkImageviewer2. Then I just see a white image. All white.

But my surprise was that, adding the render window interactor, when I press
r... the image appears! So I looked into the class code. I saw the reset
event and how it sets color window and color level. I've tried doing this,
with poor results.

Why do I have to reset the window/level to see the image? I can do zoom,
and rotate... around the white plane.

I did a widget->Update() or a imageViewer->Render() with the same result.

Thank you.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/vtkusers/attachments/20140814/70f336bf/attachment.html>

More information about the vtkusers mailing list