[vtkusers] VTK 5.6.0 Cmake Errors

John Drescher drescherjm at gmail.com
Thu Jun 17 11:31:46 EDT 2010

On Thu, Jun 17, 2010 at 11:23 AM, Scott Johnson
<Scott.Johnson at neuwave.com> wrote:
> Thanks John.
> I changed the binaries path to be outside i:/VTK5.6.0 to i:/VTK-Build, with the same result.  The error message still calls out that it is trying to add the Utilities directory within VTK5.6.0.  That puzzles me.  Full error text is:
> CMake Error at CMakeLists.txt:1251 (ADD_SUBDIRECTORY):
>  add_subdirectory not given a binary directory but the given source
>  directory "I:/VTK5.6.0/Utilities" is not a subdirectory of "i:/VTK5.6.0".
>  When specifying an out-of-tree source a binary directory must be explicitly
>  specified.
> I also tried deleting the cmake cache.  With the same result.
> I'm not a cmake expert by any means, but the offending line in CmakeLists.txt is:
> It seems that it should be adding it under i:/VTK-Build rather than i:/VTK5.6.0.  How is the root directory specified to ADD_SUBDIRECTORY?  There do seem to be a number of other directories already created in VTK-Build.  Just not Utilities.

Clear the cache and build with the default options the first time. I
will verify that this works on my system in a few minutes. I have both
VTK5.6 and visual studio 2008.


More information about the vtkusers mailing list