[vtkusers] VTK 5.6.0 Cmake Errors

Scott Johnson Scott.Johnson at neuwave.com
Thu Jun 17 10:07:04 EDT 2010

Hi Folks,


I'm attempting to move to VTK 5.6.0.  I'm building it on Windows XP with
Visual Studio 2008 using CMake 2.8.1 and downloaded the vtk-5.6.0.zip
file from the vtk download page.


I can get rid of all the errors and warnings except:


CMake Error at CMakeLists.txt:1251 (ADD_SUBDIRECTORY):

add_subdirectory not given a binary directory but the given source

directory "I:/VTK5.6.0/Utilities" is not a subdirectory of

When specifying an out-of-tree source a binary directory must be



CMake Error at Common/CMakeLists.txt:299 (CHECK_FUNCTION_EXISTS):

Unknown CMake command "CHECK_FUNCTION_EXISTS".


The Utilities folder is present in the VTK5.6.0 directory.  If I move it
out of the way I run into a number of other errors.  I've tried clearing
the Cache in Cmake, deleting my Binaries directory, ... to no avail.  Do
I have to build the Utilities directory first?


Any wisdom would be appreciated.




                                -- Scott


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.vtk.org/pipermail/vtkusers/attachments/20100617/0e861868/attachment.htm>

More information about the vtkusers mailing list