[vtkusers] Resource forking problems on Mac with python and vtk

Alethea abair at viz.tamu.edu
Fri Dec 14 00:43:02 EST 2007

I believe there is some confusion about what I am trying to do. I would 
like to use python scripts with vtk. That is from a command prompt I am 
python ExampleVTK.py

Regarding David's suggestions:
I tried recompiling and installing vtk from source, including the 
commands from the wiki in my CMakeLists.txt file:


Although this compiled fine and did not break anything new, it did not 
fix my the window problem. It seems to me that the wiki help is for 
people /compiling/ vtk applications such as with C++. I don't know how 
to add these lines to an interpreted language like python.

Regarding Carlos' suggestions:
Running vtkpython has the same window problem as python. As far as I can 
tell the only difference between them is whether the PYTHONPATH variable 
has been set for you or not.
Also, I have tried copying the python executable elsewhere and typing:
/Developer/Tools/Rez -o localpythoncopy
But it seems to simply hang - no response for long minutes until I 
simply CTRL-C. Have you used Rez enough to say where I'm being really 
stupid with this?

Regarding Sean's suggestions:
What executable should I be adding this __info_plist section to? Python? 
vtk? I am not compiling any source, I am running python scripts...

thanks for all your help - (I'm learning a lot!)

More information about the vtkusers mailing list