[vtkusers] missing classes in vtk.jar

J Talis jtalis at laposte.net
Wed Jun 8 05:27:35 EDT 2005


I'm having troubles using vtk with Java.
I have downloaded Vtk release 4.2, and installed it on my
computer. (I am using jdk1.5.0_03 and Eclipse 3.0.2, under
winXP). The library works, except that some classes like
vtkPanel, vtkCanvas, vtkPanelContainer.. are missing.

I searched over the Internet and the subscribers list, and
found that vtkPanel is no more included in vtk release version.

So i tried to compile from cvs last version, using CMake and
Visual Studio. But the same classes were still missing in the
vtk.jar I got.

Then I tried to add manually those classes to my project, but
I got errors about "native methods":

Exception in thread "AWT-EventQueue-0"
java.lang.UnsatisfiedLinkError: RenderCreate
	at vtkPanel.RenderCreate(Native Method)
	at vtkPanel.Render(vtkPanel.java:133)
	at vtkPanel.paint(vtkPanel.java:153)
	at sun.awt.RepaintArea.paintComponent(Unknown Source)
	at sun.awt.RepaintArea.paint(Unknown Source)
	at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

I think it's because some of vtkPanel's methods (like Lock(),
RenderCreate()..) are not in vtkPanel.java but only in a .dll
file ?

How may I make those classes work, either included in vtk.jar
or in my project's package ?

Any ideas or experiences would be greatly appreciated.

Jerome Talis

Accédez au courrier électronique de La Poste : www.laposte.net ; 
3615 LAPOSTENET (0,34€/mn) ; tél : 08 92 68 13 50 (0,34€/mn)

More information about the vtkusers mailing list