[vtkusers] VTK, MacOS and X11

Johnny C. Norris II jnorris at mcs.anl.gov
Wed Jan 26 17:35:16 EST 2005

No, I just ran cmake and then make.  It seemed to rebuild the 
vtkRendering lib, and a quick scan of the generated makefiles didn't 
turn up any "-framework OpenGL" references.  I reran everything the way 
you suggested, but I still get the same undefined reference errors.

BTW, I don't have administrative privileges, nor do I have local access 
to either of these Macs, so I don't think that fink will help me.


Mathieu Malaterre wrote:
> Johnny,
>     Did you do :
> cmake (modify the settings)
> make rebuild_cache
> make clean (within VTK/Rendering should be enough)
> make
> Thanks
> Mathieu
> Johnny C. Norris II wrote:
>> Thanks for the suggestion.  I changed the OpenGL settings to:
>> OPENGL_gl_LIBRARY:FILEPATH=/usr/X11R6/lib/libGL.dylib
>> OPENGL_glu_LIBRARY:FILEPATH=/usr/X11R6/lib/libGLU.dylib
>> It didn't help, however.  I still get exactly the same errors.
>> I'll take a look at fink.  I'm porting an existing application, 
>> however, and would like to get it to work without a major redesign.
>> Thanks,
>> John
>> Jens Frederich wrote:
>>> please use not the opengl framework, but use the opengl lib under 
>>> /usr/X11R6/lib. The best way for vtk with X11 is, use the fink tree 
>>> (fink.sf.net)
>>> On 26.01.2005, at 22:50, Johnny C. Norris II wrote:
>>>> Hi,
>>>> I can't seem to get VTK to work on a Mac using X11.  Here are the 
>>>> highlights:
>>>> Darwin kernel version 7.7.0
>>>> gcc 3.3 (from Apple)
>>>> Latest CMake from cvs
>>>> Latest VTK from cvs
>>>> VTK_USE_X is ON
>>>> OPENGL_gl_LIBRARY:STRING=-framework OpenGL
>>>> OPENGL_glu_LIBRARY:STRING=-framework AGL
>>>> The OpenGL settings are what CMake chose.
>>>> I'm trying to display to a PC with Windows 2000 and the X server 
>>>> that's distributed with cygwin.
>>>> Everything compiles, but when I try to run something 
>>>> (GraphicsCxxTests, for example), I get a huge number of undefined 
>>>> references:
>>>> dyld: bin/GraphicsCxxTests Undefined symbols:
>>>> /usr/X11R6/lib/libGL.1.dylib undefined reference to _glAccum 
>>>> expected to be defined in OpenGL
>>>> /usr/X11R6/lib/libGL.1.dylib undefined reference to _glActiveTexture 
>>>> expected to be defined in OpenGL
>>>> etc etc etc
>>>> I'm not a Mac person, but I've tried this on two different 
>>>> up-to-date Macs administered by different people, and I've gotten 
>>>> the same results.  Is this a problem with VTK, CMake, or me?
>>>> Any help would be greatly appreciated.  Thanks!
>>>> John

John Norris
Research Programmer
Center for Simulation of Advanced Rockets

More information about the vtkusers mailing list