[vtkusers] Re: OSX VTK build with python and tcl/tk using native aqua interface not X11

Dr. Daniel James White PhD dan at chalkie.org.uk
Thu Dec 2 05:49:00 EST 2004

Hi Dave,

if you want a native aqua interface (Not X11)  osX 10.3  VTK build with 
python and tcl/tk
it is possible and quite easy, as I did it yesterday....
I used the CVS version of VTK, which might not have all the VTK 
fubnctionbs working.
But la least VTK volume rendering in mayavi is working.

if you follow the instructions at the mayavi wiki, then you should get 
it working.
couple of weird things: middle and right mouse buttons are reversed 
(use a 3 button usb mouse)
and the middel button seems to be sticky, ie keeps acting as if it is 
being pressed when it isnt.... must be a bug in tcl/tk aqua.

I will update the mayavi wiki today with my latest instructions



On 2 Dec 2004, at 11:07, vtkusers-request at vtk.org wrote:

> Hi,
> I'm trying to get VTK with Python support compiled on Mac OS X 10.3.
> I'm a long time Linux and Solaris user but just getting started with OS
> X so I'm not up on all the changes that need made.
> I found this and tried following the same instructions:
> http://www.vtk.org/pipermail/vtkusers/2004-October/076684.html
> I installed python 2.4 (I thought I read there were some improvements
> with shared libraries for OS X in python 2.4) using:
> ./configure --prefix=/Users/dreed/py24 --enable-shared
> BASECFLAGS=-fno-common
> make
> make install
> then downloaded VTK. I've tried both 4.2 and 4.4. I seem to get farther
> with 4.4. I made certain the CMakeCache.txt file points out my new
> python. VTK seems to want Tk which doesn't appear to be on my Mac. Is
> there a specific Tk I should download and install?
> Compiling 4.4 finally dies when trying to:
> Building object file vtkTkRenderWidgetPython.o...
> It complains about some conflicting declarations of various X functions
> (included some below) but the real problem seems to be I don't have a
> tkMacOSX.h file. I didn't seem to have Tk on my Mac but do have some
> Tcl files in:
> /System/Library/Frameworks/Tcl.framework
> VTK seems to need Tk so I installed Tk using darwinports.org but that
> doesn't seem to have that file. Can anyone help me get vtk installed
> with Python (darwinports.org doesn't include Python support in its VTK
> port).
> Thanks,
> Dave
Dr. Daniel James White BSc. (Hons.) PhD
Cell Biology, Ambiotica C242
Department of biological and environmental science
PO Box  35
University of Jyväskylä
Jyväskylä FIN 40014
+358 14 260 4183 (work)
+358 468102840 (mobile)

dan at chalkie.org.uk
white at cc.jyu.fi

More information about the vtkusers mailing list