[vtkusers] False DISPLAY :0.0

Tom G. Smith (Smitty) smitty at kcc.com
Mon Oct 28 11:15:44 EST 2002

Hello vtkusers,

One of my coworkers pointed out that Cone.cxx isn't
meant to be interactive, so I tried compiling Cube.cxx from
Examples/DataManipulation/Cxx/Cube.cxx, and although I can interact
with it (zoom, rotate, move, quit), I still get these errors when I
run it:

	bash-2.05a$ ./Cube
	Xlib: connection to ":0.0" refused by server
	Xlib: No protocol specified

The CMakeLists.txt for Cube.cxx is essentially identical to that
I used for Cone.cxx shown below.

>From smitty at random.kcc.com Fri Oct 25 18:12:40 2002
>Date: Fri, 25 Oct 2002 18:11:47 -0500 (CDT)
>From: "Tom G. Smith (Smitty)" <smitty at random.kcc.com>
>To: vtk mailing list <vtkusers at public.kitware.com>
>Cc: Chris Pieper <Chris.Pieper at kcc.com>
>Subject: Can't interact remotely with binary from Cone.cxx
>Hello vtkusers,
>I just installed VTK 4.0.2, and you may've seen the problem I posted
>about getting Tcl scripts to work.  I'm having a similar problem with
>C++ files.  I compile Cone.cxx with these commands:
>	mkdir Cone; cd Cone
>	vtkbuildmake Cone # Builds CMakeLists.txt, listed below, runs cmake.
>	make
>It compiles clean, but when I run it remotely I get the same error as
>with Tcl scripts (Note that my $DISPLAY is *NOT* set to :0.0):
>	bash-2.05a$ ./Cone
>	Xlib: connection to ":0.0" refused by server
>	Xlib: No protocol specified
>The graphic of the cone displays, and slowly revolves, but there's
>absolutely no interaction.  The mouse and keyboard don't do anything.
>To stop the display I must do Ctrl-C.  All other X clients work fine,
>e.g. xterm, xclock, MATLAB, Mathematica, SAS, etc.
>Here's my CMakeLists.txt file (BTW cmake takes some getting used to.
>Can't say I like it very much):
>INCLUDE (${CMAKE_ROOT}/Modules/FindVTK.cmake)
> /opt/vtk/Imaging/Testing/Cxx /opt/vtk/Rendering /opt/vtk/Hybrid
> /opt/vtk/Patented /opt/vtk/Parallel /opt/vtk /opt/vtk/Common
> /opt/vtk/Filtering /opt/vtk/Imaging /opt/vtk/Graphics /opt/vtk/IO
> /opt/vtk/Utilities/zlib /opt/vtk/Utilities/png /opt/vtk/Utilities/jpeg
> /opt/vtk/Common/Testing/Cxx /usr/include/python1.5
> /contrib/vtk/VTK/bin /usr/X11R6/lib
> vtkRendering vtkGraphics vtkImaging vtkFiltering vtkCommon
> GL Xt SM ICE X11 Xext pthread m dl
>ADD_EXECUTABLE(Cone Cone.cxx)

This e-mail is intended for the use of the addressee(s) only and may contain privileged, confidential, or proprietary information that is exempt from disclosure under law.  If you have received this message in error, please inform us promptly by reply e-mail, then delete the e-mail and destroy any printed copy.   Thank you.


More information about the vtkusers mailing list