[vtkusers] Linking wih X ?

Nils H. Busch nilsb at cns.mpg.de
Fri Sep 28 09:22:00 EDT 2001


I have just downloaded and compiled vtk version 3.2 . That worked fine.
I have written  a small app to extract isosurfaces reading from file and
writing to file the polydata output.. There is no graphics i/o involved.

Strangely, the linker complains about undefined symbols : XtString,
XtShellStrings,  applicationShellWidgetClass in libVTKGraphics.so when
linking my app, not when trying to link libVTKGraphics.so. I have tried
building vtk with and without X (still compiles the X related stuff)
with the same result.
When link with Xt in my app, everything works fine, however, I don't
especially like linking with the X libs for an app that should not need
any window manager/graphics i/o.
Does anyone know how to fix this ?


 Best regards,
                                         Nils H. Busch

    Max-Planck-Institute of Cognitive Neuroscience
    Phone:                     ++49 (341) 9940-234
    Fax:                       ++49 (341) 9940-204
    E-Mail:                       nilsb at cns.mpg.de

More information about the vtkusers mailing list