[vtkusers] Makefile

Jingyi Jin jinjingyi at yahoo.com
Wed Sep 19 23:23:04 EDT 2001


I tried to compile the cone.xx in Linux, but I
couldn't get it to work. First I tried to compile it
in the vtk root directory with the following command:

g++ -o cone cone.cxx

Many error messages appeared. Then I tried to use the
following Makefile:
objects = vtkRenderWindow.o vtkRenderer.o
vtkRenderWindowInteractor.o vtkConeSource.o
vtkPolyDataMapper.o vtkActor.o

exe: $(objects)
	c++ -g -o cone $(objects)
lixo.o: cone.cxx vtkRenderWindow.h vtkRender.h
vtkRenderWindowInteractor.h vtkConeSource.h
vtkPolyDataMapper.h vtkActor.h

But no success also. I'm quite lost. If I'm doing
something absurd please let me know and give me some
instruction of how I am supposed to compile it.

I found instructions in VTK-Linux-HOWTO to add a new
class in the local/ directory, but no lines about
running the examples. 

Thanks for your kind attention. 



Terrorist Attacks on U.S. - How can you help?
Donate cash, emergency relief information

More information about the vtkusers mailing list