[vtkusers] Solaris Compilation error....

Audrius Stundzia adv_biologic at hotmail.com
Tue May 22 18:32:58 EDT 2001

Hi Marietta,

I ran into the same problem on my sun sparcstation running solaris 6.

>From what I recall this was a sun specific problem with their X11 libraries 
not satisfying part of the C++ ansi standard.

My quick and dirty solution was to add -fpermissive to the CXX flag
in the vtk user.make file.

Hope this works for you.



>From: "Marietta E. Cameron" <mcameron at bsc.edu>
>To: <vtkusers at public.kitware.com>
>Subject: [vtkusers] Solaris Compilation error....
>Date: Tue, 22 May 2001 15:55:18 -0500
>I am trying to compile vtk3.2 on the a sun workstation....
>Solaris Os 5.6
>I am receiving a compiler error on the include file Xutil.h:
>/usr/openwin/include/X11/Xutil.h:363 ANSI C++ forbids declaration 
>with no type....
>This message is repeated for almost each declaration in Xutil.h.....
>Has anyone else encounter this problem and what was the solution?
>I am compiling with Sun Workshop Compiler C++ .... but I have also tried 
>with no success.
>Suggestions anyone?
>Thank you in advance for any assistance you can offer.

Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

More information about the vtkusers mailing list