[vtkusers] Exception in a Java application

Carlos Martinez Burgos cmarbur at iti.upv.es
Fri Mar 30 02:38:31 EST 2001

Hi all.

I have successfully compiled VTK on RedHat 7.0, updating rpms from RH
webpage. I can run examples in c++, tcl and python, but when I try to run
a Java application I get this exception:

Exception in thread "main" java.lang.UnsatisfiedLinkError:
/usr/local/vtk3.2/lib/libVTKGraphics.so: undefined symbol: XtStrings
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1382)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1306)
        at java.lang.Runtime.loadLibrary0(Runtime.java:749)
        at java.lang.System.loadLibrary(System.java:820)
        at es.iti.sidgeipa.cliente.Main.<clinit>(Main.java:9)

I have included the line
        static { System.loadLibrary("vtkJava"); }
on the main class to load the library.

I run the same program on RH 6.2, whith vtk3.2 rpms installed, and
everything is OK.

I configured VTK with this command:
./configure  --prefix=/usr/local/vtk3.2 --with-x --with-opengl \
--with-tkwidget --with-shared --with-tcl --with-java --with-python \
--with-patented --with-contrib

Has somebody the same problem? Have you solved it?


Carlos Martínez Burgos      |     Instituto Tecnológico de Informática
Ingeniero Informático       |      Universidad Politécnica de Valencia
Tlf: +34 963877237          |                        Camí de Vera, S/N
cmarbur at iti.upv.es          |                   46071 Valencia - Spain
www.iti.upv.es/~cmarbur     |                           www.iti.upv.es

More information about the vtkusers mailing list