[vtkusers] Re:a 'new' RedHAt 7.0 Compile Problem

David Gobbi dgobbi at irus.rri.on.ca
Thu Mar 29 04:45:57 EST 2001

Hi Carlos,

The best way to set up user.make under Linux (or under any UNIX that
has tcl/tk properly installed) is

TCL_LIB= -ltcl8.0

TK_LIB= -ltk8.0

If you do this, then VTK will should be able to find the libraries
as long as they are located in the library path and will also be
able to load either .a or .so libraries just fine.

 - David

  David Gobbi, MSc                    dgobbi at irus.rri.on.ca
  Advanced Imaging Research Group
  Robarts Research Institute, University of Western Ontario

On Thu, 29 Mar 2001, Carlos Martinez Burgos wrote:

> Hi again.
> Yes, I'm stupid.
> I have been able to compile VTK on RH7.0 with updates from RedHat website.
> When you unzip and untar the source of vtkm the file "user.make" has two
> lines of environment variables for TCL/TK that point to their
> libraries. They point to files with ".a" extension. So, when I tried to
> compile VTK, I searched this libraries in the rpm's of TCL/TK. I found two
> libraries libtclstub8.3.a and libtkstub8.3.a to which I set the variables.
> Yesterday, I tried compile VTK again, but this time I set TCL_LIB and
> TK_LIB to libtcl.so and libtk.so files instead of these with ".a". I run
> configure and gmake again and everything was right. No error message and
> no segmentation fault.
> I'm a new person. If somebody has the same problem that's the
> solution. Sorry for all and thanks.
> Greetings.

More information about the vtkusers mailing list