[vtkusers] Re:a 'new' RedHAt 7.0 Compile Problem

Carlos Martinez Burgos cmarbur at iti.upv.es
Tue Mar 27 03:50:44 EST 2001

Hello again.

I have built VTK again on RedHat 7.0 in my work but I have the same
problem. Here I don't have an NVIDIA accelerator. I had updated to
glibc-2.2 and gcc-2.96-69 from rh70 updates (not had downgraded to

I used the user.make file attached.
I run configure as this:
./configure --prefix=$HOME/vtk3.2 --with-opengl --with-tkwidget 
--with-shared --with-tcl --with-java --with-python --with-patented 

I built using gmake and I get the error attached.

I solved this error changing in tcl/Makefile file:
vtk:    Makefile tkAppInit.o ${TOOLKIT_DEPENDS} 
        $(CXX) -o vtk tkAppInit.o \
        ${XLIBS} -lXext -lXt ${X_PRE_LIBS} -lX11 ${X_EXTRA_LIBS} -lm


vtk:    Makefile tkAppInit.o ${TOOLKIT_DEPENDS} 
        $(CXX) -o vtk tkAppInit.o \
        ${XLIBS} -lXext -lXt ${X_PRE_LIBS} -lX11 ${X_EXTRA_LIBS} -lm


Now I run a tcl script and get a segmentation fault. If I run vtk with no
scripts I get a segmentation fault too.

At home, I built VTK on a Athlon 1000MHz with a NVIDIA Geforce2 MX card
with RedHat 7.0 with glibc updated to 2.2 and with gcc downgraded to 2.95
and I had the same problems.

On another computer, a Pentium 166MMX with a SVIRGE card with Mandrake
7.2, I get the same error and after solve it, I get a segmentation fault
too. Here I run python some examples and run OK but not in tcl.

I think that the problem is change ${VTK_SHLIB_LINK_FLAGS} by
${VTK_SHLIB_BUILD_FLAGS} on tcl/Makefile. What can I do to solve the

I don't know what happends. Why I can't get a successfull compilation of
VTK? What can I do? I think that I'm stupid.

Thanks in advance.

PS: Sorry for my english but I don't know exactly how to express myself.

On Fri, 16 Mar 2001, Jason RILEY wrote:

> Dear all,
> Just a note to say we now have vtk(tcl/tk) running under RedHat 7.0.
> Thanks for the help.
> The solution for us was as follows(The key issue appears to have been, for us, 
> the RH7 compiler):
> TCL/Tk - preinstalled 8.3 with RH7
> OpenGL - installed using the nvidia drivers available on their site for the 
> GEForceII
>          (plus: changing the line in the X config file for the graphics card 
> from
>                 driver = "nv" to driver = "nvidia")
> Compiler - downgrading to gcc2.95 with the glibc2.2 patch (rpms from redhat or
>            gcc site(can't remember which - sorry)
> NOTE: problem with this is we had to leave the separate kernel compiler on for 
> later use, so uninstalling the old rpms for gcc2.96(the RH7 release version) 
> didn't work to
> well - it leaves some old libstdc libraries in /usr/lib the new libraries get 
> installed to /usr/local/lib to get round this we had to add /usr/local/lib to 
> LD_LIBRARY_PATH (or you could move the files/create the appropriate links).
> anyway all that said and done vtk is now running quite happily on RH7
> I don't know if this will be of help to anyone who still has problems but I 
> thought I'd send this in case it helps anyone.
> Thanks again for your help,
> Jason
> ------------------------------------------------------------------------------
> Jason Riley                     PhD Student
> Computer Science Department
> University College London       Telephone:      ucl: 3876
> Gower Street                               external: +44 (0)20 7679 3876
> London                        
> WC1E 6BT                        WebPage: http://www.cs.ucl.ac.uk/staff/J.Riley
> UK                                     
> ------------------------------------------------------------------------------
> _______________________________________________
> This is the private VTK discussion list. 
> Please keep messages on-topic. Check the FAQ at: <http://public.kitware.com/cgi-bin/vtkfaq>
> Follow this link to subscribe/unsubscribe:
> http://public.kitware.com/mailman/listinfo/vtkusers

Carlos Martínez Burgos      |     Instituto Tecnológico de Informática
Ingeniero Informático       |      Universidad Politécnica de Valencia
Tlf: +34 963877237          |                        Camí de Vera, S/N
cmarbur at iti.upv.es          |                   46071 Valencia - Spain
www.iti.upv.es/~cmarbur     |                           www.iti.upv.es
-------------- next part --------------
# this file can be used to override any of the values selected
# by configure in system.make.  At a minimum you should set
# the following Tcl/Tk values if you are planning to use Tcl/Tk




# for python you must set this 

# Add additional CFLAGS and CXXFLAGS for compilation
# uncomment the following two lines to set your own flags

# if you want to try the java support you'll need to set the following
# variables to match your environment and uncomment them
JAVA_INCLUDES=-I${JDKHOME}/include -I${JDKHOME}/include/linux
JAVA_CXX_LIB=/usr/lib/libiberty.a /usr/lib/gcc-lib/i386-redhat-linux/2.96/libstdc++.a /usr/lib/gcc-lib/i386-redhat-linux/2.96/libgcc.a
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: vtk-error.txt
URL: <http://www.vtk.org/pipermail/vtkusers/attachments/20010327/dfeb53a5/attachment.txt>

More information about the vtkusers mailing list