[vtkusers] Compiling VTK 3.2 on RedHat 7.0

Carlos Martinez Burgos cmarbur at iti.upv.es
Wed Mar 7 12:54:49 EST 2001


I have problems compiling VTK 3.2 on RedHat 7.0. I fill the user.make file
set the CLASSPATH for Java wrappers. Then I run ./configure with this
command line:

./configure --prefix=/usr/local/vtk3.2 --with-shared --with-tcl \
--with-java --with-python --with-tkwidget --with-patented --with-contrib

I configure it without --with-mesa and --with-opengl because of I think
opengl option is suposed.

Then I run gmake and everything is OK until vtk binary file (TCL) is
compiled. It reports an error with something about __sysconf.

To solve this error I change USING_VTK_LINK_LIBS directive (I don't
rememer well) by USING_VTK_BUILD_LIBS in the Makefile of tcl
subdirectory. Everything is allright now.

The problem is that when I run programs compiling cxx or with vtk binary
file I get a segmentation fault.

Could you tell me the correct way to run VTK 3.2 on RedHat 7.0?


Carlos Martínez Burgos      |     Instituto Tecnológico de Informática
Ingeniero Informático       |      Universidad Politécnica de Valencia
Tlf: +34 963877237          |                        Camí de Vera, S/N
cmarbur at iti.upv.es          |                   46071 Valencia - Spain
www.iti.upv.es/~cmarbur     |                           www.iti.upv.es

More information about the vtkusers mailing list