[vtkusers] Python, Windows, VTK DLL problem

Julian Humphries julian at essaustin.com
Tue Feb 6 15:29:04 EST 2001

I think I am going crazy.  I have now tried on two machines, with two
different Python distributions to get VTK to work within the Python
environment.  All are under NT.  In every case I get the follow message:

>>> from vtkpython import *
Traceback (innermost last):
  File "<interactive input>", line 1, in ?
ImportError: DLL load failed: The specified procedure could not be found.

I am working from the binary distributions, not compiling it myself.  I
tried both the standard and nightly distribution of vtkpython.  No

I searched the archives and came across the following solutions all of
which I tried:

ADD PYTHONPATH=E:\Python20\vtkpython to the Environment (with the vtk .py
and .dll files here)

Add E:\Python20\vtkpython to the python path in the registry (this seems to
work as the activeware pathviewer shows the python files as being in the
path, but the call to import vtkpython.dll still gives the above error

Add a file named vtkpython.pth (with E:\Python20\vtkpython as contents) to
the Python20 directory.

Copied vtkpython.dll to a whole bunch of different directories under

Alas, none of these work, I always get the same error message.  There must
be a straight foward solution, but i have about given up finding it by
trial and error.


Julian Humphries
University of Texas

More information about the vtkusers mailing list