[vtkusers] source install not working with TCL

Wolfram H Volpi whv88240 at Bayou.UH.EDU
Wed Oct 11 14:20:33 EDT 2000

I tried a source install at school (SiliconGraphics, NT 4.0, MS VS 6.0 C++
compiler), but vtk-tcl does not work.
After finishing the source install, I run hello.tcl and get this Windows
error on the first call to vtk:

	Error in startup script
	! invalid command name "vtkRenderer"
	  while executing
	"vtkRenderer ren1"
	 (file "C:\VTK31CD\vtk\graphics\examplesTcl\hello.tcl" line 11)

I get the same error if I install debug version, optimized version,
incremental linking, or normal linking.
I get the same error if I copy the dll files into C:\Winnt\system 
I get the same error if I set PATH (to the directories where the .dll
files were created) and then reboot.

All teh old vtk*.dll files were deleted.
In pcmaker I have the following options: "Local" in not checked, and "Build
Tcl" is checked.
I used nmake from MS-DOS to compile.

When I run C:\Program Files\Tcl\lib\tk8.2\demos\widget.tcl  TCL works
I have VTK source install on my home computer (Athlon, NT 4.0, same
compiler) working fine.

Any ideas on what the problem might be?

Thank you in advance,
Wolfram Volpi.

More information about the vtkusers mailing list