[vtkusers] ImageData WholeExtent/Dimensions problem

John Biddiscombe j.biddiscombe at rl.ac.uk
Fri Oct 6 12:39:06 EDT 2000

Lisa & Charles,

I suspect I'm doing something bad.
I'm using my RPD pipeline editor and the filters are connected to
an inspector object, the inspector always does


because I've had my fingers burnt too many times before with dodgy
extents (as Charles will have noted - c.f. ImageClip etc etc).

Inside the filter, I've basically copied the code from
ImageShrink3D because its doing almost exactly the same as my
filter with the difference that mine has 2 inputs and combines
them before averaging - AND I'm not using the multithreaded

In ExecuteInformation, I compute the output extents and set things
up, then in execute I set the scalars and off I go. I've solved
the problem of the dimensions being 0,0,0 by simply ignoring them
and using the WholeExtent instead (I'm not multi-threading so no
problem here). However, it does seem that the dimension is staying
at 0,0,0 ALL the time (but only in my filters!). I'm confused. I
guess the fault is mine own so don't waste time looking for a bug
which may not exist. If I haven't fixed it by Monday, then I'll
start whining properly.

thanks & ttfn

John B

More information about the vtkusers mailing list