vtkGeneralTransform
David Gobbi
dgobbi at irus.rri.on.ca
Wed May 31 16:00:06 EDT 2000
Hi All,
I'm planning to commit several changes to vtkGeneralTransform and
associated classes (including the venerable vtkTransform) either
tomorrow or Friday. The nightly builds might be unstable for a day or
two (hopefully not more).
The most important changes are as follows:
1) The new vtkTransform has a SetInput() method, so that you can set
a transform to be the same as an existing transform _plus_ whatever
additional rotations/translations/concatenations you apply. There
is a pipeline mechanism to ensure that the transform will update when
necessary.
2) The vtkLinearTransformConcatenation (awful name) that I added recently
will be deprecated and (soon) removed, because you will be able to
concatenate transforms using vtkTransform instead. Ditto for
vtkPerspectiveTransformConcatenation.
3) The internals of vtkGeneralTransform and the associated classes have
been re-organized to reduce code duplication.
4) vtkThinPlateSplineTransform is much more robust than it used to be
5) a new class, vtkGridTransform, allows you to specify a warp
transformation by defining an xyz grid of displacement vectors.
There is one thing which I am planning to remove: the
vtkTransform::Transpose() method. The reason I'm doing this
is because matrix transposition is incompatible with the new
SetInput()-style transform pipeline. If your code uses Transpose(),
then you will get a warning message but your code should still work.
You can still use vtkMatrix4x4::Transpose().
If anyone has any questions/comments about these changes or about the
existing vtkGeneralTransform class heirarchy and pipeline, I'd be glad
to hear them.
- David
--
David Gobbi, MSc dgobbi at irus.rri.on.ca
Advanced Imaging Research Group
Robarts Research Institute, University of Western Ontario
--------------------------------------------------------------------
This is the private VTK discussion list. Please keep messages on-topic.
Check the FAQ at: <http://public.kitware.com/cgi-bin/vtkfaq>
To UNSUBSCRIBE, send message body containing "unsubscribe vtkusers" to
<majordomo at public.kitware.com>. For help, send message body containing
"info vtkusers" to the same address.
--------------------------------------------------------------------
More information about the vtkusers
mailing list