problems on AIX

Dave Semeraro semeraro at
Fri Jan 7 12:57:23 EST 2000

I am trying to use vtk on an IBM RS6000. I would like to contact people on
the list with experience on this platform. In particular are there any tips
on building and use that one should know about. I was able to build vtk
after editing the make files by hand. configure left in the -ptall and
flags (sgi) and things built after I removed them. This indicates to me that
configure must have been confused somehow. Looking at the log it seems to
have only gotten as far as the pthread test.. but I am rambling. I was able
to execute some c++ tests (all that I tried worked actually). I ran into
when I tried to create an isosurface for a 6 million cell dataset. Segfaults
in vtkDataSetAttributes::InterpolateTuple. The line:
double *to = ((vtkDoubleArray *)toData)->WritePointer(idx,numComp);
seems to return a null pointer. toData is a vtkDataArray. No error message
is generated (by vtk). it just segfaults when it tries to assign a value to
*to. So that is where it stands so far. Any help, tips etc would be

Dave Semeraro Ph.D.
Site Scientific Visualization Lead
ASC MSRC Wright Patterson Airforce Base

Visualization and Virtual Environments Group
NCSA University of Illinois
605 E. Springfield Ave.
Champaign, IL 61820
semeraro at
(217) 244-1852

This is the private VTK discussion list.  Please keep messages on-topic.
Check the FAQ at: <>
To UNSUBSCRIBE, send message body containing "unsubscribe vtkusers" to
<majordomo at>.  For help, send message body containing
"info vtkusers" to the same address.     Live long and prosper.

More information about the vtkusers mailing list