Pb: VTK and Java on SGI

Randy Heiland heiland at ncsa.uiuc.edu
Fri Sep 10 09:14:37 EDT 1999

On Sep 10,  9:06am, Jan Ehrhardt wrote:
> Subject: Pb: VTK and Java on SGI
> Sorry, I have still problems with VTK and Java.
>  I can compile VTK --with-java sucessfully and the lib*Java.so will
> be created.
> "javac sphere.java" works fine,
> but java sphere fails with the error message:
> passat:~/tmp/vtk/vtk/java/vtk$java sphere
> java.lang.UnsatisfiedLinkError: no vtkJava in shared library path
>         at java.lang.Runtime.loadLibrary(Runtime.java:440)
>         at java.lang.System.loadLibrary(System.java:569)
>         at
>         at sphere.<init>(sphere.java:27)
>         at sphere.main(sphere.java:86)
> But the Path of the lib*Java.so is in the LD_LIBRARY_PATH. And the location
> the vtk-java classes is in the CLASSPATH.
> I have compiled with the -o32 and -n32 option -- both fails with the error
> above.
> What do I miss ?
> Regards,
> 	Jan
>-- End of excerpt from Jan Ehrhardt

I experienced this same problem a few months ago when trying to help someone
else run a VTK-Java application that I'd written.  It worked fine on my Irix
6.4 machine.  When we tried to run it on her 6.5 machine, we saw the error you
describe above.  We went to a different 6.5 machine and it worked!  I simply
wrote it off as missing (rld) patches and our solution was to use the machine
on which it worked :)

However, I too await your solution...


This is the private VTK discussion list.  Please keep messages on-topic.
Check the FAQ at: <http://www.automatrix.com/cgi-bin/vtkfaq>
To UNSUBSCRIBE, send message body containing "unsubscribe vtkusers" to
<majordomo at gsao.med.ge.com>.  For help, send message body containing
"info vtkusers" to the same address.     Live long and prosper.

More information about the vtkusers mailing list