[vtk-developers] vtk-developers Digest, Vol 95, Issue 46

David Gobbi david.gobbi at gmail.com
Mon Mar 26 16:47:52 EDT 2012


Hi Andrew,

Two years ago when I re-wrote the python wrappers, I considered
adding python 3 support but I couldn't justify it at that time.  Of
course, the use of python 3 has become more widespread since then.

There are three issues:
1) the code examples have to be made compatibile with python 3
2) the python C API has changed slightly (e.g. all strings are unicode in Py3K)
3) VTK/Python uses old-style classes, which aren't Py3K compatible

Already I've switched some classes to Py3K-compatible new-style
classes, e.g. vtkVector, vtkVariant, and all other classes not derived
from vtkObjectBase.  The vtkObjectBase-derived classes still need
to be converted, though.  It's possible to support both Python2 and Py3K
with the same codebase.

 - David


On Mon, Mar 26, 2012 at 2:13 PM, Andrew Maclean
<andrew.amaclean at gmail.com> wrote:
> Hi All,
>
> From memory the issue of removing TCL was also raised in the VTK ARB
> discussion at one stage. Personally I have no objection, I moved to Python
> ages ago for prototyping.
>
> If TCL tests in VTK are not using the classes with numerals in their names
> at present I wouldn't bother, clearly the user base for TCL is shrinking
> because, if this was not so, this issue would have been raised in the past.
>
> As a priority in the modularisation process, I would support changing:
> vtk2DHistogramItem, vtk3DSImporter, vtk3DWidget
>  to
> vtk2DHistogramItem, vtkImporter3DS, vtkWidget3D
> As this will prevent naming issues should VTK ever become a namespace. This
> would be consistent with which seems to occur in the other class names,
> namely putting 2D or 3D or a numeral at the end of the class name.
>
> I think that the textbook and users guide will need to have a lot of changes
> when VTK is modularised, maybe this is where we use Python instead of TCL
> for the examples.
> I would be glad to help in this process.
> One issue though ... what about Python3? I would suggest we only support
> Python 2.7 in existing code in order to make transitioning easier. Without
> looking at the python code in detail I don't think this will be a major
> issue.
>
> Regards
> Andrew
>
>>
>>
>>
>> ---------- Forwarded message ----------
>> From: Will Schroeder <will.schroeder at kitware.com>
>> To: Aashish Chaudhary <aashish.chaudhary at kitware.com>
>> Cc: VTK Developers <vtk-developers at vtk.org>, Bill Sherman
>> <shermanw at indiana.edu>
>> Date: Mon, 26 Mar 2012 15:08:37 -0400
>> Subject: Re: [vtk-developers] Modularization, Context2D and Tcl
>> I have no philosophical issue with removing TCL. Please note however that
>> somebody is going to have to do a lot of work to rewrite two VTK books
>> (textbook and user's guide) not to mention a hell of a lot of examples.
>> Aashish are you volunteering?
>>
>> W
>>
>> On Mon, Mar 26, 2012 at 3:04 PM, Aashish Chaudhary
>> <aashish.chaudhary at kitware.com> wrote:
>>>
>>> I know at least one person (Bill, cc'd) using  TCL wrapping
>>> but recently he switched to Python (not completely though).  My personal
>>> vote is +1 to remove TCL support.
>>>
>>>
>>> On Mon, Mar 26, 2012 at 3:00 PM, Biddiscombe, John A. <biddisco at cscs.ch>
>>> wrote:
>>>>
>>>> +1 for dropping TCL support :)
>>>>
>>>> -----Original Message-----
>>>> From: vtk-developers-bounces at vtk.org
>>>> [mailto:vtk-developers-bounces at vtk.org] On Behalf Of Marcus D. Hanwell
>>>> Sent: 26 March 2012 17:50
>>>> To: Jean-Christophe Fillion-Robin
>>>> Cc: VTK Developers
>>>> Subject: Re: [vtk-developers] Modularization, Context2D and Tcl
>>>>
>>>> So, for now I have applied a mapping of numerals to Roman numerals, and
>>>> that works well. The TCL objects have the 2 replaced by II, everything else
>>>> remains as is. This is a possible option too, although I am not particularly
>>>> tied to the name.
>>>>
>>>> None of these classes were ever wrapped in Tcl or Java as we failed to
>>>> add the handwritten code to make them part of those wrapped imports.
>>>> This is not automated, but it does beg the question of how many Tcl
>>>> users are out there and if they are largely supporting legacy Tcl scripts
>>>> and not looking at new API.
>>>>
>>>> Marcus
>>>>
>>>> On Sun, Mar 25, 2012 at 11:19 PM, Marcus D. Hanwell
>>>> <marcus.hanwell at kitware.com> wrote:
>>>> > That was my other thought, although at this stage the 3D stuff is so
>>>> > new and small it hardly seems worth it. It also looks ugly to me, but
>>>> > I could learn to live with it. As a policy it looks like we must only
>>>> > allow letters a-z to guarantee it will work everywhere (or do some
>>>> > weird transform for Tcl).
>>>> >
>>>> > On Sun, Mar 25, 2012 at 11:11 PM, Jean-Christophe Fillion-Robin
>>>> > <jchris.fillionr at kitware.com> wrote:
>>>> >> Good point.
>>>> >> On the other want if we still want to maintain the difference, what
>>>> >> about "ContextThreeD" and "ContextTwoD" ?
>>>> >>
>>>> >> Jc
>>>> >>
>>>> >> On Sun, Mar 25, 2012 at 10:58 PM, Marcus D. Hanwell
>>>> >> <marcus.hanwell at kitware.com> wrote:
>>>> >>>
>>>> >>> Hi,
>>>> >>>
>>>> >>> Tcl has been an adventure. It appears that Tcl modules are not
>>>> >>> allowed to have numbers in them, and so Rendering/Context2D and
>>>> >>> Views/Context2D will have to change. Perhaps their names can simply
>>>> >>> be Context, and that would remove the oddness that the 2D context
>>>> >>> modules have some 3D rendering code in there too.
>>>> >>>
>>>> >>> Marcus
>>>> >>> _______________________________________________
>>>> >>> Powered by www.kitware.com
>>>> >>>
>>>> >>> Visit other Kitware open-source projects at
>>>> >>> http://www.kitware.com/opensource/opensource.html
>>>> >>>
>>>> >>> Follow this link to subscribe/unsubscribe:
>>>> >>> http://www.vtk.org/mailman/listinfo/vtk-developers
>>>> >>>
>>>> >>
>>>> >>
>>>> >>
>>>> >> --
>>>> >> +1 919 869 8849
>>>> >>
>>>> _______________________________________________
>>>> Powered by www.kitware.com
>>>>
>>>> Visit other Kitware open-source projects at
>>>> http://www.kitware.com/opensource/opensource.html
>>>>
>>>> Follow this link to subscribe/unsubscribe:
>>>> http://www.vtk.org/mailman/listinfo/vtk-developers
>>>>
>>>> _______________________________________________
>>>> Powered by www.kitware.com
>>>>
>>>> Visit other Kitware open-source projects at
>>>> http://www.kitware.com/opensource/opensource.html
>>>>
>>>> Follow this link to subscribe/unsubscribe:
>>>> http://www.vtk.org/mailman/listinfo/vtk-developers
>>>>
>>>
>>>
>>>
>>> --
>>> | Aashish Chaudhary
>>> | R&D Engineer
>>> | Kitware Inc.
>>> | www.kitware.com
>>>
>>> _______________________________________________
>>> Powered by www.kitware.com
>>>
>>> Visit other Kitware open-source projects at
>>> http://www.kitware.com/opensource/opensource.html
>>>
>>> Follow this link to subscribe/unsubscribe:
>>> http://www.vtk.org/mailman/listinfo/vtk-developers
>>>
>>>
>>
>>
>>
>> --
>> William J. Schroeder, PhD
>> Kitware, Inc.
>> 28 Corporate Drive
>> Clifton Park, NY 12065
>> will.schroeder at kitware.com
>> http://www.kitware.com
>> (518) 881-4902
>>
>> _______________________________________________
>> vtk-developers mailing list
>> vtk-developers at vtk.org
>> http://www.vtk.org/mailman/listinfo/vtk-developers
>>
>
>
>
> --
> ___________________________________________
> Andrew J. P. Maclean
>
> ___________________________________________
>
> _______________________________________________
> Powered by www.kitware.com
>
> Visit other Kitware open-source projects at
> http://www.kitware.com/opensource/opensource.html
>
> Follow this link to subscribe/unsubscribe:
> http://www.vtk.org/mailman/listinfo/vtk-developers
>
>



More information about the vtk-developers mailing list