[vtk-developers] Popular class name: vtkArrayMap
Timothy M. Shead
tshead at sandia.gov
Thu Sep 17 11:27:20 EDT 2009
Berk Geveci wrote:
> I would leave the one in ParaView alone since KWCommon is (possibly)
> used by other projects. If you wanted to get rid of both, we should
> consider getting rid of the use of KWCommon in ParaView.
> On Wed, Sep 16, 2009 at 12:07 PM, Jeff Baumes <jeff.baumes at kitware.com> wrote:
>> PV ArrayMap : Made April 2002, in several PV releases, used by
>> vtkPVGeometryFilter, has companion class vtkArrayMapIterator whose
>> name would also need to be changed.
>> VTK ArrayMap : Made April 2008, in VTK 5.2 and VTK 5.4, used by
>> vtkGraphMapper (which is deprecated).
>> Yes, I'd say the PV one wins, and we should change the name of the VTK one.
>> On Wed, Sep 16, 2009 at 11:50 AM, Timothy M. Shead <tshead at sandia.gov> wrote:
>>> We have two classes named vtkArrayMap, one in VTK/Rendering, and another in
>>> ParaView/Common/KWCommon. I'm inclined to rename the former to something
>>> along the lines of "vtkMapArrayValues", any thoughts?
I left the ParaView class alone and converted the VTK vtkArrayMap to
vtkMapArrayValues ... it's in CVS now.
More information about the vtk-developers