[vtk-developers] bug 8513, updating freetype; need Windows dev to help

Moreland, Kenneth kmorel at sandia.gov
Tue Dec 15 14:55:56 EST 2009

Well, I'm not really sure how to compile 32 bit on blackrose.  I tried simply adding -m32 to the C and CXX flags, but the configure failed.  (It might be because there are no 32 bit Python libraries.)  Are there any other 64 bit machines that can be tried?


On 12/15/09 12:38 PM, "Sean McBride" <sean at rogue-research.com> wrote:

On 12/15/09 12:22 PM, Moreland, Kenneth said:

>This morning I noticed that a bunch of the ParaView tests were failing
>on blackrose that were not failing yesterday.
>I eventually noticed that all the tests were in some way printing
>characters on the screen.  Using a debugger, I discovered that an
>internal freetype object named clazz, which holds a bunch of function
>pointers for various font manipulations, appears to be set to garbage.
>See the screen captures to see the stack trace right before the crash
>and the odd values stored for function pointers.  The crash occurs when
>it tries to run the request_size function.
>I ran the same test on my Mac and saw that the function pointers were
>set to valid functions.  For example, the request_size function is set
>to T1_Size_Request (defined in the freetype source file t1objs.c).  I
>observe that the names of most of the functions defined in the clazz
>object are not mangled.  Could it be on blackrose that somehow pointers
>from a different library are somehow interfering with function pointers
>to the local library?


I noticed from your screenshots that you were running in 64 bit.  Did
you run in 64 bit on your Mac too?  I wonder if the pointers are being
truncated by being converted to a 32bit 'int' somewhere.  Could you test
in 32 bit on blackrose and in 64 bit on your Mac?

Sean McBride, B. Eng                 sean at rogue-research.com
Rogue Research                        www.rogue-research.com
Mac Software Developer              Montréal, Québec, Canada

   ****      Kenneth Moreland
    ***      Sandia National Laboratories
*** *** ***  email: kmorel at sandia.gov
**  ***  **  phone: (505) 844-8919
    ***      web:   http://www.cs.unm.edu/~kmorel

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/vtk-developers/attachments/20091215/d3e21c2f/attachment.html>

More information about the vtk-developers mailing list