[Paraview-developers] Re: [vtk-developers] A PT mapper for VTK

Ken Martin ken.martin at kitware.com
Tue Dec 21 13:47:17 EST 2004


> Moreland, Kenneth wrote:
> > I just wanted to give everyone a heads-up that I plan to add an
> > unstructured grid volume renderer to VTK.  Because this is the first
> > projection based unstructured grid volume rendering mapper added to VTK,
> > there are also several support classes that also have to be added.  The
> > classes are:
> >
> > vtkProjectedTetrahedraMapper: the vtkUnstructuredGridVolumeMapper
> > implemented with the PT algorithm.
> >
> > vtkVisibilitySort: an abstract class that performs a visibility sorting
> > of a collection of cells.
> >
> > vtkCellCenterDepthSort: a simple implementation of a vtkVisibilitySort
> > that provides an approximate sorting based on the location of cell
> > centers.
> >
> > vtkSort: a simple class that provides functions for sorting
> > vtkDataArrays.
> >
> > I also have tests for vtkProjectedTetrahedraMapper and vtkSort.
> >
> > Unless there are any objections, I plan to add these classes tomorrow
> > morning.
> 
> I've just discussed this with some other developers and we'd like to let
> these classes mature in ParaView before moving them to VTK.  Please
> commit these classes in the ParaView/Servers/Filters directory or
> anoather appropriate place in ParaView first.

O.K. It was my suggestion to add these to ParaView and it wasn't a great
response. Given that you are talking about adding what I would call
framework classes they eventually need to end up in VTK so why screw around
with ParaView. My real response should have been "I don't have time to look
into this right now can it wait?" But I hate saying that. My bad. O.K. So I
took some time to look at this and while I haven't looked into it in detail
I do have a couple meta level comments. 

1) The sorting classes sound like they do something similar to the existing
polydata cell sorting class that already exists. vtkDepthSort or something
like that. How do these classes relate to that class? Can they be combined?
Etc. 

2) vtkSort is a very generic name. If it is designed to sort data arrays
then can we call it vtkSortDataArray ? If it is more generic then I would
look at it from the other point of view, what does it not sort? Does it
encapsulate a single sorting algorithm or many? E.g. is this a quicksort
sorter?

Thanks for the heads-up and checking-in in the morning. Both are best
practices.

Thanks Again
Ken







More information about the vtk-developers mailing list