[vtk-developers] Re: vtkAmoebaMinimizer

David Gobbi dgobbi at irus.rri.ca
Wed Jun 12 10:07:42 EDT 2002


Hi Will,

Thanks for your comments.  If there is anything else, don't hesitate
to email me.

On Wed, 12 Jun 2002, Will Schroeder wrote:

> A couple of things about the class vtkAmoebaMinimizer:
>
> 1. There is a memory leak (see the Purify results that we finally got to
> work). It looks like in the method SetParameterBracket:

This will be fixed ASAP.

> 2. I find the use of the word "bracket" as in SetParameterBracket() to be
> less than ideal. How about SetParameterRange() ? Even in your documentation
> you describe the method with the word "range" so I think it's a better word
> than "bracket."

I agree that 'Bracket' is bad.  Even worse, the word 'bracket' has a
specific meaning wrt 1-dimensional minimization that doesn't match with
the way I've used the word here.

Perhaps the best solution is to split it into two methods, similar to
the ITK optimizers:

  SetInitialParameterValue(const char *name, double value);
  SetParameterScale(const char *name, double scale);

I'm also considering changing the name of the 'GetResult' method,
since most people connect the word 'Result' of an optimization
with the final parameter values.  It could be changed to e.g. 'GetCost.'

There was also the comment by Jim Miller that this class would be more
useful if it was placed in Common.  If I do so, then I will probably
change the name of the class to vtkAmoebaOptimizer (to better match ITK
naming) and split off a vtkAbstractOptimizer at the same time.

Cheers,

 - David




More information about the vtk-developers mailing list