[vtk-developers] vtkParse.y seems to work okay.

Lorensen, William E (CRD) lorensen at crd.ge.com
Mon Jun 18 14:57:29 EDT 2001

Please do not commit it tonight since 192 files have changed today... Wait for a stable day....

-----Original Message-----
From: Prabhu Ramachandran [mailto:prabhu at aero.iitm.ernet.in]
Sent: Monday, June 18, 2001 2:45 PM
To: vtk-developers at public.kitware.com
Subject: RE: [vtk-developers] vtkParse.y seems to work okay.


>>>>> "DG" == David Gobbi <dgobbi at irus.rri.ca> writes:

    DG> I'm innocent!  Or at the very least, I can't remember exactly
    DG> what I did to build these.  As far as I recall, I just used
    DG> 'yacc' on a RedHat 6.2 system.  I can't for the life of me
    DG> remember why I used byacc that one time, or why I was trying
    DG> to use the IRIX yacc either.


I did a little poking around on a RedHat machine I have access to and
found that RH ships with byacc *and* bison.  The yacc on Redhat
actually is that of byacc (which btw is the Berkeley LALR parser

$ rpm -qf /usr/bin/yacc

My machine however had yacc == bison 1.28.

Now on the RH machine I ran yacc -v vtkParse vtkParse.y on the current
vtkParse.y and it worked.  I have to test it out though.  I have just
installed byacc on my Debian machine and will try out on the nightly
sources.  If it works okay I will commit the new vtkParse.tab.c and
hopefully end all this madness. :)


vtk-developers mailing list
vtk-developers at public.kitware.com

More information about the vtk-developers mailing list