[Paraview] ParaViewWeb Error - vtkweb-loader.js

Mariam mbahameish at gmail.com
Thu Jun 29 06:31:42 EDT 2017


I am trying to run ParaViewWeb using the following command:

./pvpython -dr ../Resources/web/visualizer/server/pvw-visualizer.py --content ../Resources/web/visualizer/www


The connection is established, however, when accessing http://localhost:8080, I receive the following error in the browser (checked from Chrome Developer Tools):

vtkweb-loader.js Failed to load resource: the server responded with a status of 404 (Not Found)

localhost/:15 Uncaught ReferenceError: vtkWeb is not defined at localhost/:15


>From the command line, I receive the following:

[HTTPChannel,0,] "" - - [29/Jun/2017:10:23:14 +0000] "GET /lib/core/vtkweb-loader.js HTTP/1.1" 404 145 "http://localhost:8080/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.104 Safari/537.36"


ParaView version: 5.2

OS: Mac


I tried to look for /lib/core/vtkweb-loader.js, but this location doesn’t exist in the current version. It seems to be existed in older versions such as 5.1, so I tried to install 5.1 as well but I got the same error.


Any idea on how to resolve the issue? 



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://public.kitware.com/pipermail/paraview/attachments/20170629/9a4ffcbb/attachment.html>

More information about the ParaView mailing list