[Paraview] VRUI connection ParaView Crash

Aashish Chaudhary aashish.chaudhary at kitware.com
Thu Feb 13 14:36:54 EST 2014

On Thu, Feb 13, 2014 at 2:30 PM, Emiliano Pastorelli <hogancito at gmail.com>wrote:

>  Hi Aashish,
> I tried first with the VRui2.7 (that should still have the old protocol)
> and then installed and configured the newer VRUi, the 3.1-002 and I had the
> identical problem with both of them.
> Tomorrow from the office i can send you the state file, but it's a pretty
> basic one, almost identical to the example one in the Immersive Paraview
> help page.

I see. We can ask you to review this another branch. I will send you
information on that separately.

> Thanks for the interest, if I could get the working branch it would be
> ideal for me.
> Also do you happen to have any idea on why i seem to have the
> failed-handshake/mismatching client-server version problem with the 4.1
> Paraview? Is it a known issue or my problem only? As I said, with the 4.0 i
> don't experience that problem.

If both your client and server are built from the same version that you
should not see this.

> Best regards,
> H
> Il 13/02/14 21:22, Aashish Chaudhary ha scritto:
>  On Thu, Feb 13, 2014 at 2:32 AM, Emiliano Pastorelli <hogancito at gmail.com
> > wrote:
>> Hi,
>> after some time in which i had to dedicate myself to other software, i
>> finally had a chance to come back to paraview to work and develop on it.
>> I'm trying to re-set it up on my 3-screens VR setup with magnetic
>> tracking of the user position and wand and a wiimote to get the buttons. I
>> have a VRUI server that joins the tracker and the wiimote, but there seems
>> to be no way to get it working in ParaView.
>> I tried with a VRPN server and it works correctly, tracking and all, but
>> unfortunately i need the VRUI one to join buttons. As soon as i configure
>> everything in the VRPlugin (i tried both ways, through the GUI and through
>> the state file) and I start it, paraview gets stuck, mouse pointer
>> hourglass shaped and no sign of life nor error message until i have to kill
>> the process.
>  What version of VRUI you are trying to use. Some time ago, VRUI changed
> its protocol and I believe the master version is not updated to it. Also,
> can you send use the state file or VR file you are trying to use?  We do
> have a branch that supposed to fix it. Let me know and we can point you to
> it.
>> I tried with the 3.98 and the 4.0, with the 4.1 i seem to have a
>> mismatching between the client and server version and therefore the
>> handshake seems to fail because of that.
>> Any idea?
>> Best,
>> H
>> _______________________________________________
>> Powered by www.kitware.com
>> Visit other Kitware open-source projects at
>> http://www.kitware.com/opensource/opensource.html
>> Please keep messages on-topic and check the ParaView Wiki at:
>> http://paraview.org/Wiki/ParaView
>> Follow this link to subscribe/unsubscribe:
>> http://www.paraview.org/mailman/listinfo/paraview
>  --
> | Aashish Chaudhary
> | R&D Engineer
> | Kitware Inc.
> | www.kitware.com

| Aashish Chaudhary
| R&D Engineer
| Kitware Inc.
| www.kitware.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.paraview.org/pipermail/paraview/attachments/20140213/7d71aba3/attachment-0001.html>

More information about the ParaView mailing list