[Paraview] Probe filter Dual Input
shawn mckenzie
shawn.mcknezie at gmail.com
Wed Jun 14 11:55:20 EDT 2006
Thanks alot, Berk. It does just what i had expected.
Much appreciated.
Shawn
On 6/14/06, Berk Geveci <berk.geveci at gmail.com> wrote:
>
> Try the attached xml (just a few minor modifications). Make sure that the
> surface you want to probe with is the input, the data you are probing is the
> source.
>
>
> <SourceProxy name="SurfaceProbeFilter" class="vtkPProbeFilter">
> <InputProperty
> name="Source"
> command="SetSource">
> <ProxyGroupDomain name="groups">
> <Group name="sources"/>
> <Group name="filters"/>
> </ProxyGroupDomain>
> <DataTypeDomain name="input_type"
> composite_data_supported="1">
> <DataType value="vtkDataSet"/>
> </DataTypeDomain>
> </InputProperty>
> <InputProperty name="Input" command="AddInput"
> clean_command="RemoveAllInputs" multiple_input="1">
> <ProxyGroupDomain name="groups">
> <Group name="sources"/>
> <Group name="filters"/>
> </ProxyGroupDomain>
> <DataTypeDomain name="input_type">
> <DataType value="vtkDataSet"/>
> </DataTypeDomain>
>
> </InputProperty>
> </SourceProxy>
>
> <Module name="SurfaceProbeFilter"
> root_name="surfProbe"
> replace_input="0"
> menu_name="Surface Probe Filter"
> module_type="Filter"
> long_help="surfProbe"
> short_help="surfProbe">
> <Filter class="vtkPProbeFilter">
> <Input name="Input" class="vtkDataSet"/>
>
> <Input name="Source" class="vtkDataSet"/>
> </Filter>
> <InputMenu trace_name="Source"
> property="Source"
> label="Source"
> help="Select the object to evaluate."
> input_name="Source"
> initialize_with_current="0"/>
> <InputMenu trace_name="Input"
> property="Input"
> label="Input"
> help="Set the input for this filter."
> input_name="Input"/>
> </Module>
>
> On 6/14/06, shawn mckenzie <shawn.mcknezie at gmail.com > wrote:
> >
> > Hi all,
> > Revisiting an earlier post, I have included a General Probe filter that
> > allows for the user to probe object A with any object B (as opposed to only
> > point or line). I can bring the filter up for any object but my secondary
> > input is not accessible (attachment Screenshot-Kitware ParaView1.png).
> >
> > I am using Paraview 2.5 (to allow dual input). On certain objects (
> > currently only the output of dual streamTracer), my filter enables the
> > second input. Still, the probe does not funtion as expected (it does not
> > probe on boundary, but recolours the whole object A over object B's colour
> > map, still the opposite of what i would like).
> >
> > I have included my .pvsm and .xml files...i have tried multiple changes
> > to these files without acheiving 100% success.
> > any help is appreciated, thanks
> > shawn
> >
> >
> > <ModuleInterfaces>
> > <ServerManagerFile name=" SurfaceProbeFilter.pvsm"/>
> > <Module name="SurfaceProbeFilter"
> > root_name="surfProbe"
> > replace_input="0"
> > menu_name="Surface Probe Filter"
> > module_type="Filter"
> > long_help="surfProbe"
> > short_help="surfProbe">
> > <Filter class="vtkPProbeFilter">
> > <Input name="Source" class="vtkDataSet"/>
> > <Input name="Input" class="vtkDataSet" quantity="Multiple"/>
> > </Filter>
> > <InputMenu trace_name="Source"
> > property="Source"
> > label="Source"
> > help="Select the object to evaluate."
> > input_name="Source"
> > initialize_with_current="0"/>
> > <InputMenu trace_name="Input"
> > property="Input"
> > label="Input"
> > help="Set the input for this filter."
> > input_name="Input"/>
> > </Module>
> > </ModuleInterfaces>
> >
> >
> > <ServerManagerConfiguration>
> > <ProxyGroup name="filters">
> > <SourceProxy name="SurfaceProbeFilter"
> > class="vtkPProbeFilter">
> > <InputProperty
> > name="Source"
> > command="SetSource">
> > <ProxyGroupDomain name="groups">
> > <Group name="Sources"/>
> > <Group name="filters"/>
> > </ProxyGroupDomain>
> > <DataTypeDomain name="input_type"
> > composite_data_supported="1">
> > <DataType value="vtkDataSet"/>
> > </DataTypeDomain>
> > </InputProperty>
> > <InputProperty name="Input" command="AddInput"
> > clean_command="RemoveAllInputs" multiple_input="1">
> > <ProxyGroupDomain name="groups">
> > <Group name="sources"/>
> > <Group name="filters"/>
> > </ProxyGroupDomain>
> > <DataTypeDomain name="input_type">
> > <DataType value="vtkDataSet"/>
> > </DataTypeDomain>
> >
> > </InputProperty>
> > </SourceProxy>
> > </ProxyGroup>
> > </ServerManagerConfiguration>
> >
> >
> >
> > On 5/19/06, shawn mckenziie < shawn.mcknezie at gmail.com> wrote:
> > >
> > > I have made the necessary changes as far as i can see:
> > > a) a second input was added to the .xml to account for the desired
> > > object probe
> > > b) <InputProperty name="Source" line in the .pvsm was modified to
> > > match the .xml
> > >
> > > I will update my source with the latest cvs version, as this is still
> > > necessary for my changes as well, correct?
> > >
> > > Thanks for the help
> > > Shawn
> > >
> > >
> > > On 5/19/06, Berk Geveci <berk.geveci at gmail.com> wrote:
> > > >
> > > > You are going down the wrong path. Look at these posts:
> > > > http://public.kitware.com/pipermail/paraview/2006-March/002747.html
> > > > http://public.kitware.com/pipermail/paraview/2006-March/002818.html
> > > >
> > > > Your problem is very similar in that you want to change the
> > > > hard-wired input of the probe filter (Stephen wanted to change the input of
> > > > the streamline filter). I will forward you the configuration files for the
> > > > stream tracer. Looking at those, you should be able to figure out how to
> > > > write a new configuration for a probe filter.
> > > >
> > > > -Berk
> > > >
> > > >
> > > > On 5/19/06, shawn mckenziie < shawn.mcknezie at gmail.com> wrote:
> > > >
> > > > > Hi,
> > > > I wish to make the probe filter take in any source as an input
> > > > object . The current Probe filter calls the "GetInput" method to set the
> > > > input as a line or point, but when i call this method with a general object,
> > > > my filter does not appear on the filter list.
> > > >
> > > > this input will allow any object so i should be ok. In the
> > > > vtkProbeFilter code i cannot find any method SetInput so i am assuming it is
> > > > inherited from above somewhere, since it works for a point/line already.
> > > >
> > > > Should i have to change my SetInput call? any suggestions
> > > > appreciated.
> > > > thanks
> > > >
> > > > _______________________________________________
> > > > ParaView mailing list
> > > > ParaView at paraview.org
> > > > http://www.paraview.org/mailman/listinfo/paraview
> > > >
> > > >
> > > >
> > > >
> > >
> >
> >
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://public.kitware.com/pipermail/paraview/attachments/20060614/6183c58e/attachment.html
More information about the ParaView
mailing list