[Paraview] vtkUniformGrid::SetDimensions(int[3])

Brad King brad.king at kitware.com
Tue Jul 12 17:25:26 EDT 2005


Randy Hudson wrote:
> FYI, I never solved this.  I got around it by using the other (three-int-argument) form of SetDimensions(), which allowed the link to finish.
> At 7/11/2005 10:57 AM, Berk Geveci wrote:
>>This is weird. vtkUniformGrid is now a subclass of vtkImageData and it
>>should inherit SetDimensions() from superclass. Am I missing something
>>here?
>>
>>On 7/11/05, Randy Hudson <hudson at mcs.anl.gov> wrote:
>>
>>>
>>>In the 07/07/2005 CVS distribution of paraview, SetDimensions is no longer
>>>defined in vtkUniformGrid, but it still is in vtkImageData.
>>>
>>>Though it should not be a problem, I'm getting an undefined reference (see the
>>>error statement, below) for it in a statement in which I call it as
>>>uniform_grid_pointer->SetDimensions.  The library that includes the call is
>>>"libFlashVTKComponents.so".  Here's the block where it's called:
>>>   func(vtkUniformGrid* ug){
>>>   int celldims[3];
>>>   if (dataset.GetDataLocation() == LocPoint) {
>>>      ug->SetDimensions(celldims);
>>>   } else if (dataset.GetDataLocation() == LocCell) {
>>>      for (int i=0; i<3; i++) {
>>>      celldims[i]++;
>>>   }
>>>      ug->SetDimensions(celldims);
>>>   }
>>>   }
>>>
>>>I'm calling it with the correct argument.
>>>
>>>And, the libraries appear in the link statement in the correct order for
>>>resolving this (see the link statement below).
>>>
>>>Should the function still be defined in vtkUniformGrid?

Are you sure that there is no old vtkUniformGrid header file that is 
getting picked up?  That would cause the linker to look for the method 
in vtkUniformGrid instead of vtkImageData.

-Brad


More information about the ParaView mailing list