[Insight-developers] enabling remote not quite right

Xiaoxiao Liu xiaoxiao.liu at kitware.com
Mon Aug 26 12:12:43 EDT 2013


Here is the ITK patch to enforce the consistency in the remote module
naming:
http://review.source.kitware.com/#/c/12444/
This requires the corresponding changes in itk-module.cmake for each of the
following remote modules:
*MGHIO, SCIFIIO, SmoothingRecursiveYvvGaussianFilter*

So Hans, Mark and I. Vidal, will you mind go ahead and change the module
name
in itk-moduel.cmake please?

I have updated the wiki page and the README file for remote modules:
http://www.itk.org/Wiki/ITK/Policy_and_Procedures_for_Adding_Remote_Modules

If later we want to implement some cmake hooks to check the name
consistency,
we could do that too.

Thanks.

-Xiaoxiao



On Mon, Aug 26, 2013 at 11:14 AM, Matt McCormick <matt.mccormick at kitware.com
> wrote:

> Hi Brad and Bill,
>
> Yes, with the recent simplifications, the ModuleName used in
>
>   itk_fetch_module(ModuleName
>
> must be the same as the name used in
>
>   itk_module(ModuleName
>
> Here is an issue to track the topic:
>
>   https://issues.itk.org/jira/browse/ITK-3203
>
> This is a logical expectation, so documenting it may be sufficient.
> If the effort required to do a check is reasonably low, that can be
> done, too.
>
>
> There are tradeoffs in the Module name policy.  If a Remote Module may
> someday be fully merged into the ITK repository, then its name will
> change, and all the modules that depend on it will need to change the
> dependency name.  On the other hand, restricting the "ITK" module
> namespace to fully merged modules could prevent naming conflicts.  I
> am not sure which is better.
>
> Thanks,
> Matt
>
>
> On Mon, Aug 26, 2013 at 2:17 PM, Bill Lorensen <bill.lorensen at gmail.com>
> wrote:
> > I had the same issue with recent changes to Remote modules. I suggest
> that
> > the fetch name and module name be the same. Also, I think Remote module
> > names should not have the ITK prefix.
> >
> >
> >
> > On Mon, Aug 26, 2013 at 10:07 AM, Bradley Lowekamp <
> blowekamp at mail.nih.gov>
> > wrote:
> >>
> >> Matt,
> >>
> >> I am trying out some modules as remote instead of External. It appears
> >> that turning them on is not as straight forward as I expected.
> Specifically,
> >> when I add a remote cmake file with the following:
> >>
> >> itk_fetch_module(ExternalTemplate
> >>   "A template for a module."
> >>   GIT_REPOSITORY http://github.com/blowekamp/itkExternalTemplate.git
> >>   GIT_TAG master
> >>   )
> >>
> >>
> >>
> >> I have to turn on Module_ExternalTemplate which downloads the module
> >> nicely. But the I get the new CMake variable Module_ITKExternalTemplate,
> >> which needs to be turned on, now this ITK prefix comes from the named
> passed
> >> to itk_module. Looked at the checked in remotes, it appears that many of
> >> them  are not consisting the the name of the remote and the name of the
> >> module with regards to the ITK prefix.
> >>
> >> What do you think should be done to make this consistent?
> >> Should external remote modules have the ITK prefix or just internal ITK
> >> modules?
> >>
> >> Perhaps when a module is downloaded or updated we should verify that the
> >> name reported in itk_fetch_module matches that in itk_module, and
> produce an
> >> error if not?
> >>
> >> Thanks,
> >> Brad
> >>
> >>
> >>
> >>
> >>
> >> _______________________________________________
> >> Powered by www.kitware.com
> >>
> >> Visit other Kitware open-source projects at
> >> http://www.kitware.com/opensource/opensource.html
> >>
> >> Kitware offers ITK Training Courses, for more information visit:
> >> http://kitware.com/products/protraining.php
> >>
> >> Please keep messages on-topic and check the ITK FAQ at:
> >> http://www.itk.org/Wiki/ITK_FAQ
> >>
> >> Follow this link to subscribe/unsubscribe:
> >> http://www.itk.org/mailman/listinfo/insight-developers
> >>
> >
> >
> >
> > --
> > Unpaid intern in BillsBasement at noware dot com
> _______________________________________________
> Powered by www.kitware.com
>
> Visit other Kitware open-source projects at
> http://www.kitware.com/opensource/opensource.html
>
> Kitware offers ITK Training Courses, for more information visit:
> http://kitware.com/products/protraining.php
>
> Please keep messages on-topic and check the ITK FAQ at:
> http://www.itk.org/Wiki/ITK_FAQ
>
> Follow this link to subscribe/unsubscribe:
> http://www.itk.org/mailman/listinfo/insight-developers
>



-- 


---------------------------------------------
*Xiaoxiao Liu*, Ph.D.
R & D Engineer
Kitware Inc <http://www.kitware.com/>.
Clifton Park, NY
Phone: (518) 881-4924  or  (518) 371-3971 x124
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.itk.org/pipermail/insight-developers/attachments/20130826/7c098cd0/attachment.htm>


More information about the Insight-developers mailing list