[Insight-developers] itk submission

Luis Ibanez luis . ibanez at kitware . com
Mon, 29 Dec 2003 11:53:15 -0500


Hi Samson,


Thanks a lot for contributing this code
and for taking the time of submitting
the experimental build.

Your classes have been commited into the
CVS repository.

http://www . itk . org/cgi-bin/cvsweb . cgi/Insight/Code/Algorithms/itkCompareHistogramImageToImageMetric . h?cvsroot=Insight&sortby=date
http://www . itk . org/cgi-bin/cvsweb . cgi/Insight/Code/Algorithms/itkKullbackLieblerCompareHistogramImageToImageMetric . h?cvsroot=Insight&sortby=date

as you can see, the "KL" was replaced with
KullbackLiebler for the sake of clarity.

Please let us know if you find any issues with
these classes.

Thanks again,


    Luis



---------------------------------------------
Samson Timoner wrote:

> This is the submission of itkCompareHistogramImageToImageMetric
>                       and itkKLCompareHistogramImageToImageMetric
> 
> I submitted an experimental build as requested (horus0.ai.mit.edu)
> 
> The files are attached. Though, for those of you who do not like
> attachments, the files are also sitting in:
> 
>  www.ai.mit.edu/people/samson/upload/itk
> 
> For Code/Algorithms, I have the following files:
> 
>   itkKLCompareHistogramImagetoImageMetric.h
>   itkKLCompareHistogramImagetoImageMetric.txx
>   itkCompareHistogramImagetoImageMetric.h
>   itkCompareHistogramImagetoImageMetric.txx
> 
> For Testing/Code/Algorithms, I have:
>   itkKLCompareHistogramImageToImageMetricTest.cxx
>   itkKLCompareHistogramImageToImageMetric.txx
> 
> In the directory Testing/Code/Algorithms, one needs to modify
> 
>  CMakeList.txt
>  itkAlgorithmsHeaderTest.cxx
>  itkAlgorithmsTests2.cxx
> 
> which I have also included.
> 
> Comments:
>   1) The class should probably be called
>      itkKullbackLieblerCompareHistogramImagetoImageMetric,
>      but as we are comparing Histograms, I think that itkKLCompare is
>      sufficient. Feel free to tell me to change it, or just do a search
>      and replace on your own.
>   2) In Testing, the test for CompareHistogramImageToImageMetric
>      effectively does almost nothing that is not contained in the test for
>      KLCompareHistogramImageToImageMetric. I basically just copied the
>      test from HistogramImageToImageMetricTest, which similarly just
>      has a simple test for a sub-class.
> 
>  I'm sure I can say more, but I think this is sufficient for now.
>  Happy Holidays everyone!
> 
> -- Samson
>