[Insight-developers] Evaluators : Lagrange, Hermite, Bezier

Luis Ibanez luis.ibanez@kitware.com
Fri, 15 Mar 2002 10:51:54 -0500


Jim,

That's right,
They fit perfectly as derived classes of  itk::SpatialFunction.

So, how about the following names:

- itk::LegendrePolynomialSpatialFunction
- itk::HermitePolynomialSpatialFunction
- itk::BersteinPolynomialSpatialFunction
- itk::SerendipityPolynomialsSpatialFunction

and maybe rename itkMultivariateLegendrePolynomial as

- itk::LegendrePolynomialSpatialFunction

It seems redundant to add "Multivariate" since
they will be N-D . This last class will need some reworking
because currently it is only supporting 2D and 3D.

By combining this Functions with Neighborhood operators
we can get a family of interpolators (with similar names )
and make them available for more combinatorial options in
the registration framework.   Currently we only have
NearesNeighbor, Linear and BSpline interpolators.



Thanks.

    Luis



=====================================

Miller, James V (CRD) wrote:

>Luis,
>
>Why introduce another concept "Evaluators"? These are just functions. They
>should cleanly in the FunctionBase design.  
>
>Jim
>
>
>