[Insight-developers] Passing arrays of parameters around: ad
ding itk::FixedArray<> ?
Miller, James V (CRD)
millerjv@crd.ge.com
Wed, 20 Feb 2002 09:36:07 -0500
Do we want FixedArray and Array or an Array (which is fixed) and a DynamicArray?
Or would DynamicArray lead people to believe that they could change its length
after constructor time?
The reason I ask is that I will probably be writing a DynamicJoinImageFilter which would join N input
images forming a vector image whose length is not known at the time the filter is constructed, making
it different from the current JoinImageFilter. I am wondering if I should pick a different name.
-----Original Message-----
From: Luis Ibanez [mailto:luis.ibanez@kitware.com]
Sent: Wednesday, February 20, 2002 8:23 AM
To: Lydia Ng
Cc: insight-developers@public.kitware.com
Subject: [Insight-developers] Passing arrays of parameters around:
adding itk::FixedArray<> ?
How about adding a variant of itk::Array<>, templated only over
the representation type and defining the Dimension (once and for all)
at construction time ( a bit like the vnl_vector_fixed class ).
We could rename the current itk::Array<> as itk::FixedArray<> and
add this new variant. Its code will be almost a copy of the current
itk::Array<>.
Luis
==================================
Lydia Ng wrote:
>
>As a group should we lock down on a consistent way of passing
>around a variable sized array for all filters
>- in some places people have used (T *) and in other
>places people have used (std::vector<T> &)
>
>Comments?
>
>- Lydia
>
_______________________________________________
Insight-developers mailing list
Insight-developers@public.kitware.com
http://public.kitware.com/mailman/listinfo/insight-developers