[Insight-developers] Passing arrays of parameters around: adding itk::FixedArray<> ?
Luis Ibanez
luis.ibanez@kitware.com
Wed, 20 Feb 2002 08:23:22 -0500
How about adding a variant of itk::Array<>, templated only over
the representation type and defining the Dimension (once and for all)
at construction time ( a bit like the vnl_vector_fixed class ).
We could rename the current itk::Array<> as itk::FixedArray<> and
add this new variant. Its code will be almost a copy of the current
itk::Array<>.
Luis
==================================
Lydia Ng wrote:
>
>As a group should we lock down on a consistent way of passing
>around a variable sized array for all filters
>- in some places people have used (T *) and in other
>places people have used (std::vector<T> &)
>
>Comments?
>
>- Lydia
>