[Insight-developers] iterators in a reverse direction?

Luis Ibanez ibanez@choroid.cs.unc.edu
Thu, 17 May 2001 13:42:04 -0400 (EDT)


I agree,
Adding the operator-- to existing iterators
seems to be a better approach.

Separating forward and reverse iterator will
only be interesting if we were passing iterators
around (eg. inputs for filters).

Luis



Josh Cates wrote:
>
> In the interest of reducing complexity, my feeling is that if there is no
> implementational reason that existing ImageIterators cannot be made
> bidirectional, they should be made bidirectional (and not broken apart
> into forward and reverse iterators).  Same functionality at a reduced code
> volume requiring fewer itk objects.  This approach also offers a bit more
> flexibility to the user.
>