[Insight-developers] Your new filter
Bill Lorensen
wlorens1@nycap.rr.com
Sun, 04 Mar 2001 08:21:15 -0500
Julien,
Good to see your new filter that computes a Danielsson distance map. I'm assuming that you built and tested it on Windows. The other platforms are a bit more strict in some C++ usage. Most of the compile errors on the SGI and gnu compilers will go away if you use the typename hint. For example:
TOutputImage::PixelType replaced with typename TOutputImage::PixelType
Also, the sgi is confused with your usage of sqrt. The arguments are of type short. Is this really what you meant? The squaring of the short's could cause overflow.
Also, neither your .h nor .txx files ended with a new line.
Lastly, I believe the filter should be called:
itkDanielssonImageFilter
or perhaps
itkDanielssonDistanceImageFilter
according to the new naming conventions we discussed in Salt Lake.
Thanks,
Bill